Студопедия

Главная страница Случайная страница

КАТЕГОРИИ:

АвтомобилиАстрономияБиологияГеографияДом и садДругие языкиДругоеИнформатикаИсторияКультураЛитератураЛогикаМатематикаМедицинаМеталлургияМеханикаОбразованиеОхрана трудаПедагогикаПолитикаПравоПсихологияРелигияРиторикаСоциологияСпортСтроительствоТехнологияТуризмФизикаФилософияФинансыХимияЧерчениеЭкологияЭкономикаЭлектроника






Реализация в среде Excel. Заполним исходные данные системы как показано на рисунке 11.6.




Заполним исходные данные системы как показано на рисунке 11.6.

В ячейку А9 вносим значение х.


Рисунок 11.6

Данную таблицу заполняем согласно условию задачи.

Для начала вычислим (t-i):

Е3=$B$11-D3……….Копируем эту формулу в ячейки Е4,Е5,Е6,Е7,Е8.

Теперь вычислим Ci

F3=((-1)^(5-D3))*ФАКТР(D3)*ФАКТР(5-D3)……………. Копируем эту формулу в ячейки F4,F5,F6,F7,F8.

Теперь вычислим (t-i)*Ci

G3=E3*F3…………..Копируем эту формулу в ячейки G4, G5, G6, G7, G8.

Теперь вычислим yi /((t-i)*Ci)

H3= B3/G3…………… Копируем эту формулу в ячейки H4, H5,H6,H7,H8.

Определяем П5+1 Е10=ПРОИЗВЕД(Е3:Е8)= -0,7024271.

Определяем :Е11= СУММ(Н3:Н8 = -1,858185.

Теперь непосредственно вычисляем f(0,1157)= П5+1* :Е12= Е10*Е11=1,30524.

Ответ: 1,30524.

 

Задания для самоконтроля.

Формула Лагранжа для неравноотстоящих значений аргумента.

А)

х у
0,43 1,63597
0,48 1,73234
0,55 1,87686
0,62 2,03345
0,70 2,22846
0,75 2,35973

Вычислить значение функции f(x)=y(x) при x=0,512.

Б)

х у
0,02 1,02316
0,08 1,09590
0,12 1,14725
0,17 1,21483
0,23 1,30120
0,30 1,40976

Вычислить значение функции f(x)=y(x) при x=0,203.

В)

х у
0,35 2,73951
0,41 2,30080
0,47 1,96864
0,51 1,78776
0,56 1,59502
0,64 1,34310

Вычислить значение функции f(x)=y(x) при x=0,482.

 


mylektsii.ru - Мои Лекции - 2015-2019 год. (0.004 сек.)Все материалы представленные на сайте исключительно с целью ознакомления читателями и не преследуют коммерческих целей или нарушение авторских прав Пожаловаться на материал