Студопедия

Главная страница Случайная страница

КАТЕГОРИИ:

АвтомобилиАстрономияБиологияГеографияДом и садДругие языкиДругоеИнформатикаИсторияКультураЛитератураЛогикаМатематикаМедицинаМеталлургияМеханикаОбразованиеОхрана трудаПедагогикаПолитикаПравоПсихологияРелигияРиторикаСоциологияСпортСтроительствоТехнологияТуризмФизикаФилософияФинансыХимияЧерчениеЭкологияЭкономикаЭлектроника






Встроенные функции EXCEL. Статистический анализ




 

Все результаты расчётов, полученные в заданиях 1-2 необходимо проверить с помощью встроенных функций EXCEL.

MS EXCEL содержит 320 встроенных функций. Простейший способ получения полной информации о любой из них заключается в переходе на вкладку Поискиз меню ?, после чего необходимо напечатать имя нужной функции и нажать кнопку Показать.

Для удобства функции в EXCEL разбиты по категориям (матаматические, финансовые, статистические и т. д.) . Зная, к какой категории относится функция, справку о ней можно получить следующим образом:

1. Щелкните на закладке Содержание в верхней части окна, а затем последовательно пункты Создание формул и проверка книг, Функции листа.

2. Щелкните название нужной категории.

3. Щелкните имя необходимой функции и ознакомьтесь с ее описанием.

Обращение к каждой функции состоит из двух частей:имени функции и аргументов в круглых скобках. Аргументы функции могут быть следующих типов:

1) Числовые константы.

=ПРОИЗВЕД(2,3) 2*3

2) Ссылки на ячейки и блоки ячеек.

=ПРОИЗВЕД(А1;С1:С3) А1*С1*С2*С3

3) Текстовые константы (заключенные в кавычки).

4) Логические значения.

5) Массивы.

6) Имена ссылок. Например, если ячейке А10 присвоить имя Сумма (последовательность команд Вставка, Имя, Определить...), а блоку ячеек В10:Е10 – имя Итоги, то допустима следующая запись:

=СУММ(Сумма;Итоги)

7) Смешанные аргументы.

=СРЗНАЧ(Группа;А3;5*3)

Формулы, содержащие функции, можно вводить непосредственно в ячейку, в строку формул или создавать с помощью Мастера функций. Для вызова Мастера функций необходимо выбрать команду Функция в меню Вставкаили нажать кнопку Мастер функций.

В открывшемся диалоговом окне выберите категорию и имя функции, а затем нажмите кнопку OK.

В полях с соответствующими подсказками впечатайте аргументы. После нажатия кнопки OK готовая функция появится в строке формул.

В приложении 2 представлены некоторые математические и тригонометрические функции EXСEL.

Пример. Вычислить значения функции

y= ex sin(x) для -1 <= x <= 1 Dx = 0.1.

Определите количество отрицательных у.

Заполним столбец А значениями аргумента функции. Чтобы не вводить их вручную, применим следующий прием. Введите в ячейку А1 начальное значение аргумента –1. В меню Правкавыберите команду Заполнить, затем Прогрессия и в открывшемся диалоговом окне укажите предельное значение (1), шаг (0.1) и направление автозаполнения (по столбцам). После нажатия кнопки ОК в столбце А будут введены все значения аргумента. В ячейке В1 введите формулу:

=EXP(A1)*Sin(A1).

Размножьте эту формулу на остальные ячейки столбца B. В итоге будут вычислены соответствующие значения функции.



Для определения количества отрицательных у в ячейку C1 введите формулу

=СЧЕТЕСЛИ (В1:В11;<0)

В результате в ячейке C1 будет вычислено количество отрицательных значений в ячейках B1:В11 (т.е. у).

Принцип действия большинства логических функций EXCEL заключается в проверке некоторого условия и выполнения в зависимости от него тех или иных действий.

Так, функция ЕСЛИ выполняет проверку условия, задаваемого первым аргументом логич_выр:

=ЕСЛИ(логич_выр;знач_да;знач_нет)

и возвращает знач_да, если условие выполнено (ИСТИНА), и знач_нет, противном случае (ЛОЖ).

Например:

I. =ЕСЛИ(А6<10;5;10).

Если значение в ячейке А6<10, то функция вернет результат 5, а иначе – 10.

II. =ЕСЛИ(B4>80;”Сданы”; ”Не сданы”).

Если значение в ячейке B4>80, то в ячейке с приведенной формулой будет записано ”Сданы”, иначе - ”Не сданы”.

III. =ЕСЛИ (СУММ(А1:А10)>0;СУММ(В1:B10);0).

Если сумма значений в столбце A1:А10 больше 0, то вычислится сумма значений в столбце B1:В10, в противном случае результат – 0.

Дополнительные логические функции

=И(логич_выр1;логич_выр2)

=ИЛИ(логич_выр1;логич_выр2)

=НЕ(логич_выр)

позволяют создавать сложные условия, например:

=ЕСЛИ(И(СУММ(А1:А10)>0;СУММ(В1:B10)>0);

СУММ(A1:B10);0).

Если суммы и в столбце А1:А10 и в столбце В1:В10 положительны, то вычислить суму значений в ячейках А1:В10, иначе – 0.

MS EXCEL предоставляет широкие возможности для анализа статистических данных. Для решения простых задач можно использовать встроенные функции. Рассмотрим некоторые из них.



1. Вычисление среднего арифметического последовательности чисел:

=СРЗНАЧ(числа).

Например: =СРЗНАЧ(5;7;9);

=СРЗНАЧ(А1:А10;С1:С10)4

=СРЗНАЧ(А1:Е20).

2. Нахождение максимального (минимального) значения:

=МАКС(числа)

=МИН(числа).

Например: =МАКС(А4:С10);

=Мин(А2;С4;7).

3. Вычисление медианы (числа, являющегося серединой множества):

=МЕДИАНА(числа).

4. Вычисление моды (наиболее часто встречающегося значения в множестве):

=МОДА(числа).

Следующие функции предназначены для анализа выборок генеральной совокупности данных.

5. Дисперсия:

=ДИСП(числа).

6. Стандартное отклонение:

=СТАНДОТКЛОН(числа).

Для решения сложных задач применяется Пакет анализа. Пакет анализаэтодополнение EXCEL, расширяющее его аналитические возможности и позволяющие строить гистограммы, составлять таблицы рангперсентиль, делать случайные или периодические выборки данных и находить их статистические характеристики, генерировать неравномерно распределенные случайные числа, проводить регрессивный анализ и многое другое. Чтобы воспользоваться инструментами анализа, выполните следующие действия:

1. В меню Сервисвыберите команду Анализ данных.

2. Выберите из списка название нужного инструмента анализа и нажмите кнопку ОК.

3. В большинстве случаев в открывшемся диалоговом окне нужно просто указать интервал исходных данных, интервал для вывода результатов и задать некоторые параметры.

Инструмент Описательная статистика формирует таблицу статистических данных, ускоряя и упрощая этот процесс по сравнению с использованием формул 1 - 6.

Инструмент Генерация случайных чисел дает возможность получать равномерное и неравномерное распределение.

Инструмент Гистограмма позволяет создавать гистограммы распределения данных. Область значений измеряемой величины разбивается на несколько интервалов, называемых карманами, в которых в виде столбцов откладывается количество попавших в этот интервал измерений, называемое частотой.

 


.

mylektsii.ru - Мои Лекции - 2015-2019 год. (0.012 сек.)Все материалы представленные на сайте исключительно с целью ознакомления читателями и не преследуют коммерческих целей или нарушение авторских прав Пожаловаться на материал