Студопедия

Главная страница Случайная страница

КАТЕГОРИИ:

АвтомобилиАстрономияБиологияГеографияДом и садДругие языкиДругоеИнформатикаИсторияКультураЛитератураЛогикаМатематикаМедицинаМеталлургияМеханикаОбразованиеОхрана трудаПедагогикаПолитикаПравоПсихологияРелигияРиторикаСоциологияСпортСтроительствоТехнологияТуризмФизикаФилософияФинансыХимияЧерчениеЭкологияЭкономикаЭлектроника






Практические работы с применением макросов.




Практическая работа №1 «Годовая температура»

 

Порядок работы:

  1. Откройте Excel.
  2. Переименуйте «Лист1» в лист «Температура».
  3. Составьте таблицу «Годовая температура»
Месяц Средняя температура
Январь -5
Февраль -6
Март
Апрель
Май
Июнь
Июль
Август
Сентябрь
Октябрь
Ноябрь
Декабрь -9
  1. В ячейку Е3 поместите значение среднегодовой температуры, рассчитав ее по формуле СРЗНАЧ(В3:D3)
  2. Запишите Ваши действия в макрос, назвав его «СрГодТемп».
  3. Привяжите макрос к графическому объекту (например, кнопка):

 
 

 


Отформатируйте ее и назначьте ей макрос «СрГодТемп».

 

  1. Справа от показателя температуры нарисуйте графический объект (кнопку) и назначьте ему макрос, который будет очищать содержимое ячейки Е3.

 

 

 

 

  1. Проверьте работу кнопок «Средне-годовая t » и «Очистить».
  2. Самостоятельно выполните создание кнопок и макросов для подсчета и очистки:

· Максимальной годовой температуры;

· Минимальной годовой температуры;

· Средняя температура по временам года (зимой, весной, летом, осенью)

· Создать кнопку «Очистить всё» для очистки всех расчетов.

 

Ваша работа должна выглядеть следующим образом:

 

 

 

Практическая работа №2 «Протяженность границ РФ»

 

Порядок работы:

  1. Откройте Excel.
  2. Переименуйте «Лист2» в лист «Границы».
  3. Составьте таблицу «Протяженность государственной границы РФ, км»

 

Участок границы Сухопутная Речная и озерная Морская
С Норвегией 43 152,8 23,3
С Финляндией 1091,7 180,1 54
С Эстонией 89,5 235,3 142
С Латвией 137,2 133,3
С Литвой 29,9 236,1 22,4
С Польшей 203,3 0,8 32,2
С Белоруссией 857,7 381,3
С Украиной 1500,2 425,6 320
С Грузией 819,4 56,1 22,4
С Азербайджаном 272,4 55,2 22,4
С Казахстаном 5936,1 1576,7 85,8
С Монголией 2878,6 606,4
С Китаем 650,3 3559
С КНДР 17,3 22,1
С Японией 194,3
С США 49

 

  1. Начиная с ячейки F3, составьте таблицу вопросов и ответов:

 

1. Суммарная протяженность морских границ  
2. Суммарная протяженность сухопутных границ  
3. Суммарная протяженность речных и озерных границ  
4. Максимальная длина границы.  
5. Минимальная длина границы.  
6. Самая протяженная граница (вид)  
7. Самая малая граница (вид)  

 



  1. Справа от таблицы нарисуйте графические объекты, к которым привяжите макросы.

  1. Для расчетов используйте формулы:
  • Ячейка H3 =СУММ(D3:D18)
  • Ячейка H4 =СУММ(B3:B18)
  • Ячейка H5 =СУММ(C3:C18)
  • Ячейка H6 =МАКС(B3:D18)
  • Ячейка H7 =МИН(B3:D18)
  • Ячейка H8 =ЕСЛИ(H6=МАКС(B3:B18);B2;ЕСЛИ(H6=МАКС(C3:C18);C2;D2))
  • Ячейка H9 =ЕСЛИ(H6=МИН(B3:B18);B2;ЕСЛИ(H6=МИН(C3:C18);C2;D2))

 

После привязки макросов к графическим объектам и их выполнения получим результат:

 

7. Установите в Меню (Сервис-Параметры-Вкладка «Вид») параметры окна,

 


mylektsii.ru - Мои Лекции - 2015-2019 год. (0.008 сек.)Все материалы представленные на сайте исключительно с целью ознакомления читателями и не преследуют коммерческих целей или нарушение авторских прав Пожаловаться на материал